设为首页收藏本站

LinuxTone | 运维专家网论坛 - 最棒的Linux运维与开源架构技术交流社区!

 找回密码
 注册

QQ登录

只需一步,快速开始

#公告#抱歉,网站将关闭,不再开放。由于PC时代已远逝 。在这个后移动互联网时代,我们继续携手前行,保持对技术的热情。共同构建linuxtone知识星球欢迎加入,一起讨论技术、招聘人才、分享资源。请新老linuxtone人 扫码移步到 知识星球:linuxtone

学习是一种信仰!分享是一种快乐!能力= 心态 * 沟通 * 知识 (你的每一天需要正能量!)

 网站的发展需要你贡献一份力量!希望你能每天坚持看贴1小时,并回答网友的问题!祝你在浏览论坛的过程中取得进步!谢谢!linuxtone加油!大家加油! 友情提示: 你今天学习了吗?你今天进步了吗?少一点抱怨!多一点进步!Life is short ! Why not linuxtone ?  

网站的发展、感谢每位坛友的努力!

查看: 4465|回复: 4

[Heartbeat] 求助!!!安装heartbeat出现问题!!! [复制链接]

Rank: 4

签到
7
注册时间
2010-9-24
最后登录
2012-5-22
在线时间
37 小时
阅读权限
50
积分
822
帖子
12
主题
3
精华
0
UID
10463
发表于 2011-3-16 23:54:49 |显示全部楼层
本帖最后由 magicstar 于 2011-3-17 09:18 编辑

测试环境:redhat5.5libtool-2.2.tar
Heartbeat-3-0-STABLE-2.1.3.tar.bz2.tar

./ConfigureMe configure

make时最后的错误提示

libtool: unrecognized option `--tag=CC'
Try `libtool --help' for more information.
gmake[2]: *** [pils.lo] 错误 1
gmake[2]: Leaving directory `/root/Heartbeat-3-0-STABLE-2.1.3/lib/pils'
gmake[1]: *** [all-recursive] 错误 1
gmake[1]: Leaving directory `/root/Heartbeat-3-0-STABLE-2.1.3/lib'
make: *** [all-recursive] 错误 1


论坛元老

小运维——知我罪我,其惟UNIX-like

Rank: 8Rank: 8

注册时间
2010-11-12
最后登录
2016-8-4
在线时间
1122 小时
阅读权限
90
积分
91360
帖子
477
主题
21
精华
0
UID
11131
发表于 2011-3-17 09:16:24 |显示全部楼层
回复 magicstar 的帖子

试下把老版本的libtool 彻底删除
下面的错误就是老版本的libtool 没有删除彻底:
libtool: unrecognized option `--tag=CC'
Try `libtool --help' for more information.



因为:libtool会使用ltmain.sh这个脚本,每次生成的时候,libtool会拷贝一个ltmain.sh到当前的程序目录中。
            你可能用的旧版本生成的ltmain.sh 里面会识别不了--tag=CC。

调整好看正常吗?
天道酬勤——UNIX真美!GNU/Linux更美!
子曰:君子务本,本立而道生!

使用道具 举报

Rank: 4

注册时间
2010-9-24
最后登录
2012-5-22
在线时间
37 小时
阅读权限
50
积分
822
帖子
12
主题
3
精华
0
UID
10463
发表于 2011-3-17 09:58:04 |显示全部楼层
本帖最后由 magicstar 于 2011-3-17 10:03 编辑

回复 lnfsddy 的帖子

我把旧的版本删除了换了更高的版本libtool-2.4.tar,安装heartbeat
./ConfigureMe configure

make时又一个问题出现
yacc  -d conf_yacc.y
gmake[2]: yacc:命令未找到
gmake[2]: *** [conf_yacc.c] 错误 127
gmake[2]: Leaving directory `/root/Heartbeat-3-0-STABLE-2.1.3/telecom/recoverymgrd'
gmake[1]: *** [all-recursive] 错误 1
gmake[1]: Leaving directory `/root/Heartbeat-3-0-STABLE-2.1.3/telecom'
make: *** [all-recursive] 错误 1







使用道具 举报

Rank: 7Rank: 7Rank: 7

注册时间
2008-9-20
最后登录
2019-9-2
在线时间
489 小时
阅读权限
100
积分
38065
帖子
2202
主题
48
精华
0
UID
307

LT元老

发表于 2011-3-17 10:41:37 |显示全部楼层
回复 magicstar 的帖子

安装yacc

使用道具 举报

Rank: 4

注册时间
2010-9-24
最后登录
2012-5-22
在线时间
37 小时
阅读权限
50
积分
822
帖子
12
主题
3
精华
0
UID
10463
发表于 2011-3-17 11:10:34 |显示全部楼层

谢谢lnfsddy和源泉星火的帮助!!!

本帖最后由 magicstar 于 2011-3-17 11:12 编辑

问题解决了,还缺少一个包bison
安装Heartbeat需要的工具包如下,之所以安装中出现了各种错都是因为缺少包导致的
依赖包如下:automake  autoconf  libtool  libnet  flex   bison

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

IT运维专家网感谢您的支持

合作联系: QQ:67888954/MSN:cnseek@msn.com/mail:netseek@linuxtone.org

Archiver|手机版|感谢所有关心和支持过LinuxTone的朋友们 转载本站内容请注明原作者名及出处 ( 京ICP备08103151 )   |

GMT+8, 2019-12-6 19:05 , Processed in 0.020528 second(s), 14 queries , Apc On.

Powered by Discuz! X2 Licensed

© 2001-2011 Comsenz Inc.

回顶部