设为首页收藏本站

LinuxTone | 运维专家网论坛 - 最棒的Linux运维与开源架构技术交流社区!

 找回密码
 注册

QQ登录

只需一步,快速开始

#公告#抱歉,网站将关闭,不再开放。由于PC时代已远逝 。在这个后移动互联网时代,我们继续携手前行,保持对技术的热情。共同构建linuxtone知识星球欢迎加入,一起讨论技术、招聘人才、分享资源。请新老linuxtone人 扫码移步到 知识星球:linuxtone

学习是一种信仰!分享是一种快乐!能力= 心态 * 沟通 * 知识 (你的每一天需要正能量!)

 网站的发展需要你贡献一份力量!希望你能每天坚持看贴1小时,并回答网友的问题!祝你在浏览论坛的过程中取得进步!谢谢!linuxtone加油!大家加油! 友情提示: 你今天学习了吗?你今天进步了吗?少一点抱怨!多一点进步!Life is short ! Why not linuxtone ?  

网站的发展、感谢每位坛友的努力!

查看: 6237|回复: 4

[MySQL管理] mysql出现Got a packet bigger than ‘max_allowed_packet’ bytes错误 [复制链接]

LT管理团队

想飞的鸟

Rank: 9Rank: 9Rank: 9

签到
223
注册时间
2008-6-20
最后登录
2015-7-7
在线时间
594 小时
阅读权限
200
积分
23002
帖子
512
主题
83
精华
3
UID
95
发表于 2011-3-25 23:27:33 |显示全部楼层


当执行sql语句的时候出现 [Err] 1153 – Got a packet bigger than ‘max_allowed_packet’ bytes 这样的错误解决方法


在不重启mysql的情况下执行这2语句增加网络包的大小可以解决:


set
global net_buffer_length=1000000;
set
global max_allowed_packet=1000000000;





<-sina_sign,1703616862,29fb6047,1->

Rank: 7Rank: 7Rank: 7

注册时间
2008-11-27
最后登录
2019-3-21
在线时间
208 小时
阅读权限
100
积分
6501
帖子
772
主题
367
精华
4
UID
632

LT同学

发表于 2011-3-26 07:02:08 |显示全部楼层
哈哈,LZ,你试过,是哪个参数让你成功解决问题吗?
http://hi.baidu.com/ytjwt/

使用道具 举报

LT管理团队

想飞的鸟

Rank: 9Rank: 9Rank: 9

注册时间
2008-6-20
最后登录
2015-7-7
在线时间
594 小时
阅读权限
200
积分
23002
帖子
512
主题
83
精华
3
UID
95
发表于 2011-3-26 08:29:52 |显示全部楼层
具体哪个不知道,只是把那个一起贴进去就ok了,之前在配置文件中配置max_allowed_packet=100M,重启后还是有问题,

我猜应该是max_allowed_packet参数在影响吧,不过这个问题可以重现,在dx1.5后台清数据缓存的时候
<-sina_sign,1703616862,29fb6047,1->

使用道具 举报

Rank: 8Rank: 8

注册时间
2010-10-18
最后登录
2012-7-19
在线时间
102 小时
阅读权限
90
积分
5606
帖子
44
主题
3
精华
0
UID
10652
发表于 2011-3-26 10:50:55 |显示全部楼层
感觉因该是高max_allowed_packet参数有关吧,,,net_buffer_length主要是影响传输效率吧,,,手册上这么描述:
The value should be a multiple of 1024; nonmultiples are rounded down to the nearest multiple.
When you change the message buffer size by changing the value of the max_allowed_packet variable,
you should also change the buffer size on the client side if your client program permits it.
On the client side, max_allowed_packet has a default of 1GB.
Some programs such as mysql and mysqldump enable you to change the client-side value by setting max_allowed_packet on the command line or in an option file.
1GB的消息缓冲,,,好大的数据量,,,

使用道具 举报

LT管理团队

想飞的鸟

Rank: 9Rank: 9Rank: 9

注册时间
2008-6-20
最后登录
2015-7-7
在线时间
594 小时
阅读权限
200
积分
23002
帖子
512
主题
83
精华
3
UID
95
发表于 2011-3-26 11:09:21 |显示全部楼层
回复 ninicyn 的帖子



这个值是直接在网上复制的,没有转换,基本上设置只对应急的情况比较好使,如果重启就就还原了
<-sina_sign,1703616862,29fb6047,1->

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

IT运维专家网感谢您的支持

合作联系: QQ:67888954/MSN:cnseek@msn.com/mail:netseek@linuxtone.org

Archiver|手机版|感谢所有关心和支持过LinuxTone的朋友们 转载本站内容请注明原作者名及出处 ( 京ICP备08103151 )   |

GMT+8, 2019-3-25 16:33 , Processed in 0.020502 second(s), 14 queries , Apc On.

Powered by Discuz! X2 Licensed

© 2001-2011 Comsenz Inc.

回顶部